Parallels Toolbox draws excessive amount of CPU when computer is not connected to internet

Discussion in 'Parallels Toolbox for Mac' started by PetrH2, Feb 24, 2018.

  1. PetrH2

    PetrH2 Bit Poster

    Messages:
    6
    The sub-system of Parallels Toolbox which is responsible for update and some sort of licensing stuff generates excessive amount of log messages while computer is not connected to internet which leads to excessive utilization of CPU. The only solution is to terminate Parallels Toolbox (if possible) and start it back on while internet connection is available. If Parallels Toolbox is re-started while the machine is still offline, the issue persists.

    One of zillions of the messages generated:
    Code:
    23.02.2018 22:37:42,675 Parallels Toolbox[12042]: Error during update: Error Domain=NSURLErrorDomain Code=-1009 "The operation couldn't be completed. (NSURLErrorDomain error -1009.)" UserInfo=0x6080006fde80 {NSErrorFailingURLStringKey=http://download.parallels.com/toolbox/v2/parallels/parallels_updates.xml, NSErrorFailingURLKey=http://download.parallels.com/toolbox/v2/parallels/parallels_updates.xml, _kCFStreamErrorDomainKey=12, _kCFStreamErrorCodeKey=8, NSUnderlyingError=0x608000845cd0 "The operation couldn't be completed. (kCFErrorDomainCFNetwork error -1009.)"}
    
     
  2. sergk

    sergk Parallels Developers

    Messages:
    141
    Hello,
    could you please generate Problem Report (Toolbox --> 'Gear' button --> Help --> Send TechnicalData), send it and post ID here?
    It will help us to investigate your problem.
     
  3. PetrH2

    PetrH2 Bit Poster

    Messages:
    6
    Here is the Id of the generated (and posted) report: 246013820
     
  4. sergk

    sergk Parallels Developers

    Messages:
    141
    Thanks for the report ID. We're going to investigating this issue.
    Btw, does the problem disappear after connecting to the Internet? And if turn Internet access OFF - does the problem return?
     
  5. DRU732

    DRU732 Bit Poster

    Messages:
    2
    I have the same issue. I have a MacBook Pro 2016. Work has a BYOD program. I use a Windows VM as my work BYOD machine.
    Each time I am in the office Parallels Toolbox generates a constant can continuous stream of errors stating that "The network connection was lost"
    I usually hear the fans kick in and notice my CPU temperature skyrocketing, before I remember to Quit the app.

    Error during update: Error Domain=NSURLErrorDomain Code=-1005 "The network connection was lost." UserInfo={NSUnderlyingError=0x6080022437e0 {Error Domain=kCFErrorDomainCFNetwork Code=-1005 "(null)" UserInfo={NSErrorPeerAddressKey=<CFData 0x608000099550 [0x7fff86db1af0]>{length = 16, capacity = 16, bytes = 0x100200506810303f0000000000000000}, _kCFStreamErrorCodeKey=-4, _kCFStreamErrorDomainKey=4}}, NSErrorFailingURLStringKey=http://download.parallels.com/toolbox/v2/parallels/parallels_updates.xml, NSErrorFailingURLKey=http://download.parallels.com/toolbox/v2/parallels/parallels_updates.xml, _kCFStreamErrorDomainKey=4, _kCFStreamErrorCodeKey=-4, NSLocalizedDescription=The network connection was lost.}

    Naturally my machine has access to the internet from the office, however we do use identity certs installed on the machine to allow access through the firewall. My machine has these certs, and I can browse the internet just fine. But Parallels Toolbox definitely has a problem.


    Report ID 260218368
     
  6. sergk

    sergk Parallels Developers

    Messages:
    141
    Hello,
    please install the latest update for Parallels Toolbox (version 2.6.0) - your issue should be fixed.
    To install update: open Toolbox -> press cogwheel (right top corner) -> Check for Updates...
     

Share This Page