Increase RDP Screen Resolution on 27" iMac 2017 (5K)

Discussion in 'Parallels Client for Mac' started by LAlf, Dec 19, 2017.

  1. LAlf

    LAlf Bit Poster

    Messages:
    7
    Hi!
    I use last iMac (Retina 5K, 27-inch, 2017) for connect to Windows Server 2012 R2 and I want to increase default screen resolution up to ~5K with same elements sizes as in MacOS. But in my connection I have 2560 x 1440 pixels screen resolution in Windows (on iMac I have 5120 x 2880 pixels).
    I trying to change resolution in RDP connection settings (Display tab), set max available params (4096 x 2048), but I recieved "scroll bars" on full-screen rdp window.
    Why?

    I work with not-resized "big canvas" with many elements in Windows and want to increase screen size (without scroll bars) for growth my performance.

    Sorry for my bad English, my first language is Russian.
     
  2. Yury Averkiev

    Yury Averkiev Parallels Support

    Messages:
    65
    Hi, thank you for reporting the problem. We shall fix in a Q1'18 update.
     
  3. LAlf

    LAlf Bit Poster

    Messages:
    7
    Thanks! Notify me in this thread after update, please.
     
  4. LAlf

    LAlf Bit Poster

    Messages:
    7
    Hello!
    It's not implemented yet?
     
  5. ikorobov

    ikorobov Parallels Developers

    Messages:
    18
    Hello, LAlf!

    Can you please check if "DPI Aware" option (Parallels Client > Preferences > Advanced) is turned on in Parallels Client?
    If it is not, please try to do the following:
    1. Open Parallels Client and connect to your remote server
    2. In the remote session, do Sign out (it's important to do Sign out, not just Disconnect)
    3. In the RDP connections settings, navigate to Display tab and choose "Full screen" or "Use available area" in the "General Options > Size" combobox.
    4. Navigate to Parallels Client > Preferences > Advanced tab and turn on "DPI Aware" option
    5. Connect to your remote server again.
    After login, resolution in the remote session should be 5120x2880.

    Best regards,
    Ivan Korobov
     
  6. LAlf

    LAlf Bit Poster

    Messages:
    7
    Ivan, thanks! It's worked! :)
    [​IMG]

    But windows (and software with whom I work) not correct use this resolution... In software resolution on their elements not changed (I think its bug on this software).
    And on notepad++ (as example) resolution has made bad:
    [​IMG]
    Tab font size is very small and not readable.

    And with this resolution my eyes got sick..))

    Thanks for this case for check 4K resolution, but I will return the previous resolution.

    PS: I use latest version of Parallels Client: 16.2.2 (build 19300)
     
  7. jpc

    jpc Kilo Poster

    Messages:
    231
    @LAlf Dpi scaling on windows/win32 applications is a bit of a hit-and-miss affair since it needs application developer support.

    As you have found out yourself, Notepad++ has only mixed dpi support.
    However, if you have a problem with only 1 specific application, you could try disabling high dpi scaling for that particular application (using the "Disable Display Scaling On High DPI Settings" option)
    https://support.microsoft.com/en-us...tions-may-appear-blurred-on-high-dpi-displays
     
    LAlf likes this.

Share This Page