Shared Network not working on Lite Version

Discussion in 'Mac OS X Guest OS Discussion' started by LucaC2, Apr 13, 2017.

  1. LucaC2

    LucaC2 Bit Poster

    Messages:
    5
    Hi,
    my configuration is
    - Host with macOS Sierra 10.12.4
    - Parallel Desktop Lite Version 1.1.0 (19626)
    - Guest with macOS Sierra 10.12.4
    - Network interface set to Shared Network
    - Inside the Guest, Ethernet Cable is connected, with
    • IP 192.168.64.3
    • mask 255.255.255.0
    • router 192.168.64.1
    • DNS 192.168.64.1
    - In the host, interface is active
    bridge100: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=3<RXCSUM,TXCSUM>
    ether f6:5c:89:aa:30:64
    inet 192.168.64.1 netmask 0xffffff00 broadcast 192.168.64.255
    Configuration:
    id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
    maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
    root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
    ipfilter disabled flags 0x2
    member: en5 flags=3<LEARNING,DISCOVER>
    ifmaxaddr 0 port 11 priority 0 path cost 0
    nd6 options=201<PERFORMNUD,DAD>
    media: autoselect
    status: active
    Problem is that inside the Guest, I cannot connect to internet, I cannot even ping the router (192.168.64.1)
    macOSSierra.png

    Thanks,
    L

     
  2. Elric

    Elric Parallels Developers

    Messages:
    1,579
    Hi, do you have McAfee installed? Unfortunately it blocks the traffic for Parallels Desktop lite, until network protection is disabled.
    http://kb.parallels.com/en/124094
     
  3. LucaC2

    LucaC2 Bit Poster

    Messages:
    5
    No, I do not have McAfee installed.

    Is there a way to debug the shared network interface to check what's happening?

    L
     
  4. Elric

    Elric Parallels Developers

    Messages:
    1,579
    Hi, I can suggest a remote session to investigate the problem. Tomorrow or other working day 11.00-17.00 UTC. I'll send my email address via forum's private messages.
     
  5. TomyP

    TomyP Bit Poster

    Messages:
    5
    Hi LucaC2,

    Your IP address is class C match with your class C subnet. It's what I can see on your screenshot. However, I don't think your host computer is also a DNS server. Firstly, try to remove in your virtual macOS (guest) the DNS numbers. Then, try to ping again in your Terminal (guest machine) www.google.com. If it doesn't work, try to put another DNS configuration in your virtual macOS (guest). Put 8.8.4.4 as your DNS. Then, try to ping again in your Terminal (guest machine) www.google.com. Let me know if you are experiencing again a problem or if it works.

    Your faithfully
    Image Parallels 27.png
     
  6. Swati@Parallels

    Swati@Parallels Parallels Support

    Messages:
    363
    Hello Tomy, thank you so much for sharing this workaround. We are glad to see your active participation and appreciate it.
     
  7. LucaC2

    LucaC2 Bit Poster

    Messages:
    5
    Hi TomyP,
    thanks for the feedback. Unfortunately this is not the case, as you can see from the screenshot.
    DNS.png
     
  8. TomyP

    TomyP Bit Poster

    Messages:
    5
    Hi LucaC2,

    In my side, I reproduced a virtual macOS machine that I made some Internet tests. It works perfectly, I am able to ping www.google.com, such as on the screenshot.

    Let's see together your host macOS built-in firewall. Such as on screenshots that I made for you, go to System preferences, Firewall tab, Firewall Options..., and uncheck the box for "Block all incoming connections" and uncheck also "Enable stealth mode". You can add on the Firewall list "Parallels Desktop Lite" and allow incoming connections for its. Click on Ok. You should also make sure that you both uncheck the box for "Block all incoming connections" and "Enable stealth mode" in your virtual macOS machine (guest).

    Yours sincerely,
     

    Attached Files:

  9. LucaC2

    LucaC2 Bit Poster

    Messages:
    5
    Firewall is off for both guest and host
    firewallOFF.png
     
  10. TomyP

    TomyP Bit Poster

    Messages:
    5
    Hi LucaC2,

    Firstly, may you try to check if you have any proxies turn on in Network setting (guest macOS)? You should deactivate proxies. Secondly, I remarked that when I enabled "Internet Sharing" in the guest macOS, my virtual machine lost its Internet connection. You should disable the "Internet Sharing" from Sharing settings in System preferences. But, it is not enough. If you did it one time in the past (Internet sharing), you have to restart the network card manually in Network, Configure IPv4, set to Off, Apply (Important!), Configure IPv4, set "Using DHCP", Apply again. Finally, I give you a screenshot on what I was talking about "Internet Sharing".
     

    Attached Files:

  11. LucaC2

    LucaC2 Bit Poster

    Messages:
    5
    Solved,
    thanks to Elric.

    I had custom packet filter rules in the host. To reset them, in the host give the following commands
    "sudo pfctl -e" -> this will enable packet
    "sudo pfctl -F all" -> this will remove all rules
    "sudo pfctl -f /etc/pf.conf" -> this will reload default rules
    then in the guest switch VM to Host Only network mode and then back to Shared -> it will refresh some internal macos states.
     

Share This Page