Parallels tools installation: permission denied in Raspberry Pi Desktop

Discussion in 'Linux Guest OS Discussion' started by RogerM7, Dec 12, 2017.

  1. RogerM7

    RogerM7

    Messages:
    1
    I have just installed the Raspberry Pi Desktop in Parallels Desktop 13 running on OSX. It runs in very low resolution and there doesn't seem to be any way of changing the resolution within the Pi Desktop.

    I'm trying to install Parallels Tools, hoping this will provide a way of setting resolution. The tools icon says to run "sudo ./install" in the /media/cdrom0 folder.
    I've navigated to this folder but when I try this I get a message "Permission denied".
    I've tried to do "sudo su" first but still get the message. Is there some other way of installing the tools or setting the resolution?
    Thanks.
     
  2. alexg

    alexg Parallels Developers

    Messages:
    543
    Parallels Tools can't be installed to Raspberry Pi Desktop. It is unsupported configuration.
     
  3. FrancescoA2

    FrancescoA2 Bit Poster

    Messages:
    2
    RaspberryPi Desktop is based on Debian, can this distribution please be supported? Thanks!
     
  4. DouglasG

    DouglasG Bit Poster

    Messages:
    4
    Running Parallels Desktop 13 and installed latest Raspberry PI Desktop - Stretch (form of Debian Linux).
    After dismounting and remounting Parallels Tools .iso with the -o exec option as stated when I used Install Parallel Tools menu item I was finally able to cd to the /media/cdrom0 device and had permission to execute "sudo ./install" script.
    Now I get an error that makes no sense to me: "./install: line 35: /media/cdrom0/installer/installer.x86_64: No such file or directory".
    Of course I checked the contents of the ...installer directory and the file noted as missing is indeed there in the correct place with exec permission.
    This makes no sense to me.
     

    Attached Files:

  5. RayG2

    RayG2

    Messages:
    1
    This whole thread is of interest to me as I am also failing to install the Parallels Tools for this OS and so am stuck with an 800 by 600 screen resolution on a 1920 by 1200 monitor - not very useful.
     
  6. VladC

    VladC Bit Poster

    Messages:
    1
    I did get past this by using
    sudo mount -o exec /dev/sr0 /mnt/cdrom
    instead of /media/cdrom. However after reboot Xorg wouldn't load due to incorrect driver architecture:
    (EE) Failed to load /usr/lib/xorg/modules/drivers/prlvideo_drv.so: /usr/lib/xorg/modules/drivers/prlvideo_drv.so: wrong ELF class: ELFCLASS64
    :(
     
  7. FongK

    FongK Bit Poster

    Messages:
    1
    I'm not sure if this is helpful, I solved the "./install: line 35: /media/cdrom0/installer/installer.x86_64: No such file or directory" problem by updating the Raspbian OS first.
    The code to update the OS can be found at: https://www.raspberrypi.org/documentation/raspbian/updating.md
    sudo apt-get update
    sudo apt-get dist-upgrade

    However, I advise not running the ./install yet as it seems to break the graphic driver. I had to create snapshots before running the ./install to narrow it down as the culprit for the problem.

    The problem of installing the Parallel Tools was that you will not be able to boot back to your desktop mode. Instead, you
    [​IMG]

    I had updated the "sources.list" code which was said to update the driver. However, I'm unable to get pass the "800x600" resolution.
     

Share This Page